Degraded Ingestion API Performance (/import)

Incident Report for Mixpanel

Postmortem

On April 15th, from 12:38 AM UTC to 12:45 PM UTC, our US /import API sent incorrect API responses for up to 10% of traffic.

During this period, some requests to the US /import API (and only this endpoint) may have received a 200 OK response, even though the events were not successfully ingested. This disruption only affected projects hosted in our US data center.

Potential Action Required

Data sent to the US /import API during this period of time will require resubmission to ensure complete data.

  • Please ensure those events maintain the same $insert_id, time, distinct_id and event name so that Mixpanel properly deduplicates any existing data.

If you exclusively use Warehouse Connectors and/or the /track API to send data to Mixpanel, no action is required.

We are committed to delivering accurate, timely analysis to support your critical decision-making, and we prioritize fast, high-quality customer support. If you have any questions or concerns, please feel free to reach out.

Posted Apr 15, 2025 - 13:59 PDT

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 13:36 PDT

Update

We are continuing to monitor for any further issues.
Posted Apr 15, 2025 - 10:16 PDT

Monitoring

From April 15th at 5:38 PM to April 16th at 5:56 AM (PST), Mixpanel experienced degraded performance in one of our ingestion APIs, /import, where some data may not have been ingested correctly. At this moment, we advise our customers to resend any requests that received an empty response along with the '200 OK' code.
This disruption only affected projects hosted in our US data center, and more information will be shared shortly.
If you have any questions, please don't hesitate to contact our Support team.
Posted Apr 15, 2025 - 07:55 PDT
This incident affected: Data Ingestion (Ingestion API Availability (US)).