Degraded Query API Performance Impacting All Reports
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted Jan 14, 2025 - 20:33 PST
Monitoring
We have identified the transient issue affecting the Query API. We have now recovered and will continue to monitor.
Posted Jan 14, 2025 - 20:32 PST
Investigating
Mixpanel is experiencing degraded Query API performance, causing latency or timeouts when loading data in reports.

We truly appreciate your patience and apologize for the inconvenience. If you have any questions, please contact support.
Posted Jan 14, 2025 - 20:11 PST
This incident affected: Query API.